aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-10-07 03:37:12 +0200
committerPřemysl Eric Janouch <p@janouch.name>2021-10-07 14:06:57 +0200
commited8b1bcdad7c430af1eef5fbe78b6ec4eb3eb60e (patch)
tree4d864fe34d2102eb1ef4812d4613c2eca7006336 /CMakeLists.txt
parent3881725904473cd9fdbd3e60cd1de2010f14d767 (diff)
downloadtdv-ed8b1bcdad7c430af1eef5fbe78b6ec4eb3eb60e.tar.gz
tdv-ed8b1bcdad7c430af1eef5fbe78b6ec4eb3eb60e.tar.xz
tdv-ed8b1bcdad7c430af1eef5fbe78b6ec4eb3eb60e.zip
Add sample dictionary downloaders/builders
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bd42553..9f07bfb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -172,6 +172,21 @@ endforeach ()
add_custom_target (tools DEPENDS ${tools})
+# Example dictionaries
+file (GLOB dicts_scripts "${PROJECT_SOURCE_DIR}/dicts/*.sh")
+set (dicts_targets)
+foreach (dict_script ${dicts_scripts})
+ get_filename_component (dict_name "${dict_script}" NAME_WE)
+ list (APPEND dicts_targets "dicts-${dict_name}")
+ add_custom_target (dicts-${dict_name}
+ COMMAND sh -c "PATH=.:$PATH \"$0\"" "${dict_script}"
+ DEPENDS tabfile
+ COMMENT "Generating sample dictionary ${dict_name}"
+ VERBATIM)
+endforeach ()
+
+add_custom_target (dicts DEPENDS ${dicts_targets})
+
# The files to be installed
include (GNUInstallDirs)
install (TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
@@ -212,4 +227,3 @@ set (CPACK_SOURCE_IGNORE_FILES "/\\\\.git;/build;/CMakeLists.txt.user")
set (CPACK_SOURCE_PACKAGE_FILE_NAME "${PROJECT_NAME}-${PROJECT_VERSION}")
include (CPack)
-