aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2022-08-02 03:04:46 +0200
committerPřemysl Eric Janouch <p@janouch.name>2022-08-04 05:23:09 +0200
commit2ff01f9fdb374695aaaa074255c5f6916d5767bf (patch)
tree5b30408c9c6efbeee00fdc6c8ce2193b7cae842b /CMakeLists.txt
parent5ed881d25bb9a73df57624d73cafb1af1638688e (diff)
downloadtdv-2ff01f9fdb374695aaaa074255c5f6916d5767bf.tar.gz
tdv-2ff01f9fdb374695aaaa074255c5f6916d5767bf.tar.xz
tdv-2ff01f9fdb374695aaaa074255c5f6916d5767bf.zip
sdgui: support text selection in the view
This is generally an improvement over the initial GtkLabel approach: - Multiple definition lines can be selected at once. - The widget doesn't keep a selection caret around (which means it can't be controlled from the keyboard, a conscious trade-off). - Text doesn't needlessly go to PRIMARY immediately during selection, making it somewhat possible lift the self-exception for the PRIMARY selection watch. Closes #2
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1d1199b..1dc1dc9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,9 +3,9 @@ project (sdtui VERSION 0.1.0 LANGUAGES C)
# Moar warnings
if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUCC)
- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
- set (CMAKE_C_FLAGS_DEBUG
- "${CMAKE_C_FLAGS_DEBUG} -Wall -Wextra -Wno-missing-field-initializers")
+ set (ignores "-Wno-missing-field-initializers -Wno-cast-function-type")
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99 ${ignores}")
+ set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Wall -Wextra")
endif ()
# For custom modules