aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2015-02-07 21:05:32 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2015-02-07 21:05:32 +0100
commita9bc1d87513c9d5cf0e45159f44d8b5dc7c9faa8 (patch)
tree89721877ad947da52e722d844896820ba6edea3a /CMakeLists.txt
parent627248bd1faca718e47941011e8099fb1b8d2223 (diff)
downloadtdv-a9bc1d87513c9d5cf0e45159f44d8b5dc7c9faa8.tar.gz
tdv-a9bc1d87513c9d5cf0e45159f44d8b5dc7c9faa8.tar.xz
tdv-a9bc1d87513c9d5cf0e45159f44d8b5dc7c9faa8.zip
Add support for watching the primary selection
Depends on GTK+, which should make it work with all of X11, Wayland, and Mir.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f3ce39b..e7ac15e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,7 @@ endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
# Build options
option (USE_SYSTEM_TERMO "Don't compile our own termo, use the system one" OFF)
+option (WITH_GTK "Compile with GTK+ support" ON)
# Version
set (project_VERSION_MAJOR "0")
@@ -39,6 +40,15 @@ else (USE_SYSTEM_TERMO)
set (Termo_LIBRARIES termo-static)
endif (USE_SYSTEM_TERMO)
+if (WITH_GTK)
+ # We actually don't care about the specific version
+ pkg_search_module (gtk REQUIRED gtk+-3.0 gtk+-2.0)
+ list (APPEND dependencies_INCLUDE_DIRS ${gtk_INCLUDE_DIRS})
+ list (APPEND dependencies_LIBRARY_DIRS ${gtk_LIBRARY_DIRS})
+ list (APPEND dependencies_LIBRARIES ${gtk_LIBRARIES})
+endif (WITH_GTK)
+
+link_directories (${dependencies_LIBRARY_DIRS})
include_directories (${ZLIB_INCLUDE_DIRS}
${dependencies_INCLUDE_DIRS} ${Termo_INCLUDE_DIRS})