aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p@janouch.name>2020-04-15 07:07:47 +0200
committerPřemysl Janouch <p@janouch.name>2020-04-15 07:07:47 +0200
commit675139edb03f1eed43361b1bc6b1bcacf63327d9 (patch)
tree4d20741fabb25c5a775432a673bf07ab3bfa5094 /CMakeLists.txt
parent1289c98ca8e3ec32f133a284569ea09ba7be4d1e (diff)
downloadtdv-675139edb03f1eed43361b1bc6b1bcacf63327d9.tar.gz
tdv-675139edb03f1eed43361b1bc6b1bcacf63327d9.tar.xz
tdv-675139edb03f1eed43361b1bc6b1bcacf63327d9.zip
Disable GLib deprecation warnings
Not very useful.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c13754f..b0cdfa4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -174,6 +174,7 @@ set (project_headers
${project_common_headers})
# Build the main executable and link it
+add_definitions (-DGLIB_DISABLE_DEPRECATION_WARNINGS)
add_executable (${PROJECT_NAME}
${project_sources} ${project_headers} ${project_common_sources})
target_link_libraries (${PROJECT_NAME} ${project_common_libraries})