aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2017-07-14 21:49:32 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2017-07-14 21:49:32 +0200
commitfb73fc8292d507e9d6f368da5f2c2ac3e3f85e45 (patch)
tree7dd42214e222460e9ca4e3261309a2133bff3926 /CMakeLists.txt
parent8c658475b44eeb1a4e4867d203c73563eb029e8f (diff)
downloadsdn-fb73fc8292d507e9d6f368da5f2c2ac3e3f85e45.tar.gz
sdn-fb73fc8292d507e9d6f368da5f2c2ac3e3f85e45.tar.xz
sdn-fb73fc8292d507e9d6f368da5f2c2ac3e3f85e45.zip
Mark files that make use of POSIX ACLs
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 03f03c2..2429e2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,7 +20,7 @@ pkg_check_modules (NCURSESW QUIET ncursesw)
add_executable (${PROJECT_NAME} ${PROJECT_NAME}.cpp)
target_include_directories (${PROJECT_NAME} PUBLIC ${NCURSESW_INCLUDE_DIRS})
-target_link_libraries (${PROJECT_NAME} PUBLIC ${NCURSESW_LIBRARIES})
+target_link_libraries (${PROJECT_NAME} PUBLIC ${NCURSESW_LIBRARIES} acl)
target_compile_features (${PROJECT_NAME} PUBLIC cxx_std_14)
target_compile_definitions (${PROJECT_NAME} PUBLIC
-DPROJECT_NAME=\"${PROJECT_NAME}\" -DPROJECT_VERSION=\"${version}\")