aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2020-09-28 04:58:27 +0200
committerPřemysl Eric Janouch <p@janouch.name>2020-09-28 04:58:27 +0200
commit0e147b2ef1be327351d21dca2e246804afc939b8 (patch)
tree50ede2656859d90c40b73a9732dff433af00dfe9 /CMakeLists.txt
parent47415fd7c65290a222a74f2c0213518abcde349c (diff)
downloadponymap-0e147b2ef1be327351d21dca2e246804afc939b8.tar.gz
ponymap-0e147b2ef1be327351d21dca2e246804afc939b8.tar.xz
ponymap-0e147b2ef1be327351d21dca2e246804afc939b8.zip
Allow Lua 5.4
It seems to build, and this entire thing is experimental anyway.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a12772..eb253b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,10 +41,10 @@ else (CURSES_FOUND)
message (SEND_ERROR "Curses not found")
endif (ncursesw_FOUND)
-# FIXME: for "lua" we also need to check that it is < 5.4
+# FIXME: for "lua" we also need to check that it is < 5.5
# which doesn't seem to be possible with FindPkgConfig
-pkg_search_module (lua lua5.3 lua-5.3 lua>=5.3)
-option (WITH_LUA "Enable experimental support for Lua 5.3 plugins" ${lua_FOUND})
+pkg_search_module (lua lua5.3 lua-5.3 lua5.4 lua-5.4 lua>=5.3)
+option (WITH_LUA "Enable experimental support for Lua plugins" ${lua_FOUND})
if (WITH_LUA)
if (NOT lua_FOUND)