aboutsummaryrefslogtreecommitdiff
path: root/src
Commit message (Collapse)AuthorAgeFilesLines
...
* Handle Edit menu actions (Delete, Select All).Přemysl Janouch2011-01-161-3/+30
|
* Use JsonObject for LdDiagramObject parameters.Přemysl Janouch2011-01-151-1/+2
| | | | Make LdDiagramObject a regular class.
* Make a separate library.Přemysl Janouch2011-01-1027-5573/+0
| | | | | | This is required for gtkdoc-scangobj. So far it's much like it's been before, the main differences are that source files are in two directories from now on and the build process has two stages.
* Use a central header.Přemysl Janouch2011-01-1012-83/+45
| | | | | | | $ time (make clean; make) Before: ~8.0 seconds After: ~8.1 seconds
* Write a signature to diagram files.Přemysl Janouch2011-01-101-7/+51
|
* Fix drawing of symbol menus.Přemysl Janouch2011-01-101-6/+7
|
* Show names of symbols in the statusbar.Přemysl Janouch2011-01-101-11/+27
|
* Remove a FIXME.Přemysl Janouch2011-01-101-1/+0
| | | | We don't really need to set the GError to anything.
* Simulate motion events when needed.Přemysl Janouch2011-01-101-4/+28
|
* Draw category icons with style colors.Přemysl Janouch2011-01-101-4/+52
| | | | Previously the icons have been black in all themes.
* Add a View menu to LdWindowMain, disabled so far.Přemysl Janouch2011-01-091-1/+13
|
* Add a "zoom" property to LdCanvas.Přemysl Janouch2011-01-092-6/+74
|
* Add hide_terminals() to LdCanvas.Přemysl Janouch2011-01-091-3/+11
|
* Add a "class" property to LdDiagramSymbol.Přemysl Janouch2011-01-091-5/+71
| | | | | Also add missing gtk-doc comments for ld_diagram_symbol_{get,set}_class().
* Make ld_lua_logdiag_register() a bit safer.Přemysl Janouch2011-01-091-4/+5
|
* Fix comments.Přemysl Janouch2011-01-097-29/+31
|
* Draw diagram objects in reversed order.Přemysl Janouch2011-01-091-5/+5
| | | | Previously older objects drew on top of newer ones.
* Replace GSList with GList in LdDiagram.Přemysl Janouch2011-01-093-33/+33
| | | | This has been an unnecessary limitation.
* Ensure that the canvas is focused.Přemysl Janouch2011-01-091-0/+5
|
* Call bind_textdomain_codeset().Přemysl Janouch2011-01-091-1/+2
|
* When zooming, focus on the cursor.Přemysl Janouch2011-01-091-0/+13
|
* Highlight symbol terminals on mouse hover.Přemysl Janouch2011-01-091-0/+114
|
* Refactor queue_object_redraw().Přemysl Janouch2011-01-091-15/+27
|
* Add ld_point_distance().Přemysl Janouch2011-01-092-0/+23
|
* Take a better approach to drawing the grid.Přemysl Janouch2011-01-081-4/+6
| | | | If the diagram is zoomed out too much, just use bigger steps between dots.
* Don't draw the grid when it would be too narrow.Přemysl Janouch2011-01-081-0/+3
| | | | This prevents eating all the memory.
* Read terminals from Lua scripts and export them.Přemysl Janouch2011-01-085-7/+113
| | | | Also add a missing part of LdSymbol API.
* Make LdCanvas zoom on mouse wheel.Přemysl Janouch2011-01-081-5/+42
|
* Introduce LdRectangle, LdPoint and LdPointArray.Přemysl Janouch2011-01-0811-147/+342
| | | | Remove LdCanvasRect and LdSymbolArea.
* Export more cairo methods to Lua.Přemysl Janouch2011-01-071-43/+129
|
* Update copyright years.Přemysl Janouch2011-01-071-2/+2
|
* Allow object selection in LdCanvas.Přemysl Janouch2011-01-071-41/+111
| | | | Refactor a part of LdCanvas in the process.
* Introduce structure LdCanvasRect.Přemysl Janouch2011-01-061-1/+40
| | | | | It's basically the same as cairo_rectangle_t, just in our own namespace.
* Change symbol clip tolerance to widget units.Přemysl Janouch2011-01-061-9/+9
| | | | As line width is in pixels, too, this makes much more sense.
* Redraw LdCanvas on LdDiagram changes.Přemysl Janouch2011-01-051-0/+31
|
* Add new objects to the start of LdDiagram's list.Přemysl Janouch2011-01-051-1/+1
| | | | | This way it doesn't have to go through the whole linked list to find a place for the objects.
* Add a "selection-changed" signal to LdDiagram.Přemysl Janouch2011-01-052-4/+30
| | | | Make existing code emit this signal.
* Add ld_diagram_{select,unselect}_all().Přemysl Janouch2011-01-052-6/+40
|
* Export cairo_{get,set}_line_width to Lua symbols.Přemysl Janouch2011-01-051-1/+37
|
* Draw selected objects with another color.Přemysl Janouch2011-01-052-7/+70
| | | | | | | | Store all colors in LdCanvasPrivate and initialize them upon object creation. This creates a base for color themes. Make attempts to try adding an object that's not a part of the document to the selection issue a warning.
* Move lines around. No functional change.Přemysl Janouch2011-01-0410-124/+117
|
* Make adding symbols to the diagram possible.Přemysl Janouch2011-01-043-3/+277
| | | | | | This required creating a simple framework for operations to LdCanvas. It is probable that it's going to require some changes when other operations are added. The basic idea behind it seems to be good, though.
* Fix the "library" property in LdCanvas.Přemysl Janouch2011-01-041-1/+1
|
* Partial refactoring of LdCanvas.Přemysl Janouch2011-01-041-48/+87
| | | | draw_symbol() had been doing too much.
* Split in-out parameters into separate in and out.Přemysl Janouch2011-01-032-25/+29
| | | | | | In functions: ld_canvas_diagram_to_widget_coords() ld_canvas_widget_to_diagram_coords()
* Fix problems discovered while testing on Windows.Přemysl Janouch2010-12-201-2/+10
| | | | | | | * Set the working directory for glib-genmarshal correctly. * Use one more path suffix when searching for glibconfig.h. * Don't assume that gdk_screen_get_resolution() returns a useful value.
* LdCanvas maintenance.Přemysl Janouch2010-12-182-25/+27
| | | | | | | | * Rename ld_canvas_translate_*_coordinates() to ld_canvas_*_to_*_coords(). * Add missing parameter assertions to those functions. * Rename local variables in draw_grid(). * Use gdk_cairo_rectangle() in expose-event handler. * Update comments.
* Make the symbol menu grab focus.Přemysl Janouch2010-12-181-1/+38
| | | | | | | | | This way when the user clicks outside the menu when it is open, the menu will close itself first. Keyboard input is however still not handled. The symbol menu should be redesigned.
* Rename LdDocument* to LdDiagram*.Přemysl Janouch2010-12-1616-1059/+1060
| | | | My bad; this name is much more appropriate.
* Overall cleanup.Přemysl Janouch2010-12-166-20/+25
| | | | | | | | | * Add missing asserts to exported functions. * Unify formatting. * Fix the gtk-doc comment for ld_symbol_category_set_human_name(). * Make ld_library_load() reflect it's declaration. * Remove an unused variable in ld_library_load_cb(). * Change all char's to gchar's.