aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-10-31 03:50:04 +0100
committerPřemysl Eric Janouch <p@janouch.name>2021-10-31 04:18:44 +0100
commit0cec1b4badd0a5e26a8143f11666295b3d5d58fa (patch)
tree4f7dfbc28558d13d99aeea7436bd960678273ce0 /CMakeLists.txt
parenta40b281078e6a4c17e1da5b98a88b07e1c533150 (diff)
downloadlogdiag-0cec1b4badd0a5e26a8143f11666295b3d5d58fa.tar.gz
logdiag-0cec1b4badd0a5e26a8143f11666295b3d5d58fa.tar.xz
logdiag-0cec1b4badd0a5e26a8143f11666295b3d5d58fa.zip
CMakeLists.txt: slightly modernize
Before version 3.12, we still need to set CPACK_PACKAGE_VERSION manually, and the subversions are actually wrongly defaulting to 0.1.1 (but we don't particularly care). FindIntl has been there since CMake 3.2.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f3d1c2a..0b39b76 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
# The last version with Windows XP support is 3.13, we want to keep that
cmake_minimum_required (VERSION 3.10)
-project (logdiag VERSION 0.2.1 LANGUAGES C)
+project (logdiag VERSION 0.2.1 DESCRIPTION "Schematic editor" LANGUAGES C)
# Options
option (OPTION_CLANG_TIDY "Enable use of clang-tidy" OFF)
@@ -164,8 +164,7 @@ endif ()
# Generate a configure file
add_definitions (-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_36)
add_definitions (-DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_36)
-configure_file (${PROJECT_SOURCE_DIR}/config.h.in
- ${PROJECT_BINARY_DIR}/config.h)
+configure_file (config.h.in ${PROJECT_BINARY_DIR}/config.h)
include_directories (${PROJECT_BINARY_DIR})
# Generate marshallers
@@ -210,8 +209,8 @@ include_directories (${GTK3_INCLUDE_DIRS} ${Lua_INCLUDE_DIRS})
set (logdiag_LIBS ${GTK3_LIBRARIES} ${Lua_LIBRARIES} m)
if (WIN32)
- find_package (LibIntl REQUIRED)
- list (APPEND logdiag_LIBS ${LIBINTL_LIBRARIES} shell32)
+ find_package (Intl REQUIRED)
+ list (APPEND logdiag_LIBS ${Intl_LIBRARIES} shell32)
endif ()
# Build the library
@@ -386,7 +385,6 @@ install (CODE " # DESTDIR is not in use on Windows (WIN32 is only native here!)
endif ()")
# CPack
-set (CPACK_PACKAGE_DESCRIPTION_SUMMARY "Schematic editor")
set (CPACK_PACKAGE_VENDOR "Premysl Eric Janouch")
set (CPACK_PACKAGE_CONTACT "Přemysl Eric Janouch <p@janouch.name>")
set (CPACK_RESOURCE_FILE_LICENSE "${PROJECT_SOURCE_DIR}/LICENSE")