aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2010-09-20 17:28:23 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2010-09-20 17:28:23 +0200
commitf675a7c07c84d71e3cee1d61bf0e0a1b800e7d0a (patch)
tree8d5cf54ab6cb8d375a791baef428d42db9ebff82 /CMakeLists.txt
parentefc3ad6f5ccfb0f63eaa197a154cbf724e3a2662 (diff)
downloadlogdiag-f675a7c07c84d71e3cee1d61bf0e0a1b800e7d0a.tar.gz
logdiag-f675a7c07c84d71e3cee1d61bf0e0a1b800e7d0a.tar.xz
logdiag-f675a7c07c84d71e3cee1d61bf0e0a1b800e7d0a.zip
Require Lua 5.1 and GTK+ 2.12.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b7b1828..18cd642 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,7 +27,7 @@ set (project_VERSION "${project_VERSION}.${project_VERSION_PATCH}")
set (CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
# Gather package information
-find_package (GTK2 2.8 REQUIRED gtk)
+find_package (GTK2 2.12 REQUIRED gtk)
# Test this machine
include (CheckCSourceCompiles)
@@ -52,6 +52,10 @@ if (WIN32)
set (HAVE_THREADSAFE_STRTOK true)
endif (WIN32)
+# Lua
+find_package (Lua51 REQUIRED)
+
+
# Localization
find_package (Gettext)
if (GETTEXT_FOUND)
@@ -130,9 +134,9 @@ glib_genmarshal (${CMAKE_CURRENT_SOURCE_DIR}/src/ld-marshal
g_cclosure_user_marshal)
# Build the executable
-include_directories (${GTK2_INCLUDE_DIRS})
+include_directories (${GTK2_INCLUDE_DIRS} ${LUA_INCLUDE_DIR})
add_executable (logdiag ${logdiag_SOURCES} ${logdiag_HEADERS})
-target_link_libraries (logdiag ${GTK2_LIBRARIES})
+target_link_libraries (logdiag ${GTK2_LIBRARIES} ${LUA_LIBRARIES})
# Installation
install (TARGETS logdiag DESTINATION bin)