aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2010-12-05 15:23:10 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2010-12-05 15:30:21 +0100
commit3d3a71d5d2be1bb14a71d03a2117eb2b317ef061 (patch)
treecc73640859ccdd3b3f61c02850922653394269d1 /CMakeLists.txt
parent1d956964e2d6b183f65620505831527a8089f697 (diff)
downloadlogdiag-3d3a71d5d2be1bb14a71d03a2117eb2b317ef061.tar.gz
logdiag-3d3a71d5d2be1bb14a71d03a2117eb2b317ef061.tar.xz
logdiag-3d3a71d5d2be1bb14a71d03a2117eb2b317ef061.zip
Prepare the project for json-glib.
This required writing a special CMake find module.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aac2c9e..694b38a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -55,6 +55,9 @@ endif (WIN32)
# Lua
find_package (Lua51 REQUIRED)
+# json-glib
+find_package (JsonGlib REQUIRED)
+
# Localization
find_package (Gettext)
@@ -146,9 +149,9 @@ glib_genmarshal (${CMAKE_CURRENT_SOURCE_DIR}/src/ld-marshal
g_cclosure_user_marshal)
# Build the executable
-include_directories (${GTK2_INCLUDE_DIRS} ${LUA_INCLUDE_DIR})
+include_directories (${GTK2_INCLUDE_DIRS} ${JSON_GLIB_INCLUDE_DIRS} ${LUA_INCLUDE_DIR})
add_executable (logdiag ${logdiag_SOURCES} ${logdiag_HEADERS})
-target_link_libraries (logdiag ${GTK2_LIBRARIES} ${LUA_LIBRARIES})
+target_link_libraries (logdiag ${GTK2_LIBRARIES} ${JSON_GLIB_LIBRARIES} ${LUA_LIBRARIES})
# Installation
install (TARGETS logdiag DESTINATION bin)