aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2010-12-18 15:39:50 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2010-12-18 17:47:37 +0100
commitb44b3e6a544c239e7581c72e73b4c5b089ffcff0 (patch)
tree1baa8e23978888aacaea219f46d9f8a1c2e54b15 /CMakeLists.txt
parent9178fb8d812f788a41b06a2c3550bf212cc0b9cf (diff)
downloadlogdiag-b44b3e6a544c239e7581c72e73b4c5b089ffcff0.tar.gz
logdiag-b44b3e6a544c239e7581c72e73b4c5b089ffcff0.tar.xz
logdiag-b44b3e6a544c239e7581c72e73b4c5b089ffcff0.zip
Documentation maintenance.
* Do not require gtk-doc to be installed. * Use FindPackageHandleStandardArgs in FindGtkDoc.cmake. * Fix installation (wrong source path). * Don't install neither the documentation nor the desktop file on Windows.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 17 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 52221d2..aba8443 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,13 +52,11 @@ if (WIN32)
set (HAVE_THREADSAFE_STRTOK true)
endif (WIN32)
-# Lua
-find_package (Lua51 REQUIRED)
-# json-glib
+# Dependencies
+find_package (Lua51 REQUIRED)
find_package (JsonGlib REQUIRED)
-
# Localization
find_package (Gettext)
if (GETTEXT_FOUND)
@@ -77,12 +75,8 @@ endif (GETTEXT_FOUND)
#set (GTK_DOC_ENABLE_HTML ON CACHE BOOL
# "Build documentation in HTML format")
-find_package (GtkDoc REQUIRED)
+find_package (GtkDoc)
set (project_DOC_DIR "${CMAKE_CURRENT_SOURCE_DIR}/docs/reference")
-GTK_DOC_RUN (WORKING_DIR ${project_DOC_DIR}
- SOURCE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/src
- XML ${project_DOC_DIR}/xml --sgml-mode
- HTML ${project_DOC_DIR}/html)
# Project source files
set (logdiag_SOURCES
@@ -153,11 +147,22 @@ include_directories (${GTK2_INCLUDE_DIRS} ${JSON_GLIB_INCLUDE_DIRS} ${LUA_INCLUD
add_executable (logdiag ${logdiag_SOURCES} ${logdiag_HEADERS})
target_link_libraries (logdiag ${GTK2_LIBRARIES} ${JSON_GLIB_LIBRARIES} ${LUA_LIBRARIES})
+# Generate documentation
+if (GTK_DOC_FOUND)
+ GTK_DOC_RUN (WORKING_DIR ${project_DOC_DIR}
+ SOURCE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/src
+ XML ${project_DOC_DIR}/xml --sgml-mode
+ HTML ${project_DOC_DIR}/html)
+endif (GTK_DOC_FOUND)
+
# Installation
install (TARGETS logdiag DESTINATION bin)
-install (FILES share/logdiag.desktop DESTINATION share/applications)
-install (DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/docs/html/"
- DESTINATION usr/gtk-doc/${CMAKE_PROJECT_NAME})
+
+if (NOT WIN32)
+ install (FILES share/logdiag.desktop DESTINATION share/applications)
+ install (DIRECTORY "${project_DOC_DIR}/html/"
+ DESTINATION usr/gtk-doc/${CMAKE_PROJECT_NAME})
+endif (NOT WIN32)
# CPack
set (CPACK_PACKAGE_DESCRIPTION_SUMMARY "Electric diagram designer.")