From e40d56152d68aa7fcf05b551e08c94d498ca9163 Mon Sep 17 00:00:00 2001 From: Přemysl Eric Janouch
Date: Thu, 2 Jan 2025 23:29:50 +0100
Subject: Add an Expect-like tool
This is to provide an Expect utility with a minimal dependency tree
for C-based projects. It also addresses some Tcl Expect design issues,
as perceived by me.
---
tools/wdye/CMakeLists.txt | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
create mode 100644 tools/wdye/CMakeLists.txt
(limited to 'tools/wdye/CMakeLists.txt')
diff --git a/tools/wdye/CMakeLists.txt b/tools/wdye/CMakeLists.txt
new file mode 100644
index 0000000..9044078
--- /dev/null
+++ b/tools/wdye/CMakeLists.txt
@@ -0,0 +1,39 @@
+cmake_minimum_required (VERSION 3.18)
+project (wdye VERSION 1 DESCRIPTION "What did you expect?" LANGUAGES C)
+
+set (CMAKE_C_STANDARD 99)
+set (CMAKE_C_STANDARD_REQUIRED ON)
+set (CMAKE_C_EXTENSIONS OFF)
+
+# -Wunused-function is pretty annoying here, as everything is static
+set (options -Wall -Wextra -Wno-unused-function)
+add_compile_options ("$<$