From 97faae7abe0ecf9ae2e9e80eba0234b4b7abe158 Mon Sep 17 00:00:00 2001 From: Přemysl Eric Janouch
Date: Thu, 2 Jan 2025 23:29:50 +0100
Subject: WIP: Add an Expect-like tool
---
tools/wdye/CMakeLists.txt | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
create mode 100644 tools/wdye/CMakeLists.txt
(limited to 'tools/wdye/CMakeLists.txt')
diff --git a/tools/wdye/CMakeLists.txt b/tools/wdye/CMakeLists.txt
new file mode 100644
index 0000000..73872ee
--- /dev/null
+++ b/tools/wdye/CMakeLists.txt
@@ -0,0 +1,24 @@
+cmake_minimum_required (VERSION 3.10)
+project (wdye VERSION 1 DESCRIPTION "What did you expect?" LANGUAGES C)
+
+set (CMAKE_C_STANDARD 99)
+set (CMAKE_C_STANDARD_REQUIRED ON)
+set (CMAKE_C_EXTENSIONS OFF)
+
+# -Wunused-function is pretty annoying here, as everything is static
+set (options -Wall -Wextra -Wno-unused-function)
+add_compile_options ("$<$