aboutsummaryrefslogtreecommitdiff
path: root/tools/wdye/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/wdye/CMakeLists.txt')
-rw-r--r--tools/wdye/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/wdye/CMakeLists.txt b/tools/wdye/CMakeLists.txt
index 9044078..a69f7ee 100644
--- a/tools/wdye/CMakeLists.txt
+++ b/tools/wdye/CMakeLists.txt
@@ -19,7 +19,10 @@ pkg_search_module (lua REQUIRED
option (WITH_CURSES "Offer terminal sequences using Curses" "${CURSES_FOUND}")
-include_directories ("${PROJECT_BINARY_DIR}")
+# -liconv may or may not be a part of libc
+find_path (iconv_INCLUDE_DIRS iconv.h)
+
+include_directories ("${PROJECT_BINARY_DIR}" ${iconv_INCLUDE_DIRS})
file (CONFIGURE OUTPUT "${PROJECT_BINARY_DIR}/config.h" CONTENT [[
#define PROGRAM_NAME "${PROJECT_NAME}"
#define PROGRAM_VERSION "${PROJECT_VERSION}"