aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2016-03-10 21:08:24 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2016-03-10 21:08:24 +0100
commit9aff11b0f5df01dee0414bd56196ef07cfcac5fb (patch)
treeef7da6526fdf35d415c5f403eb0c37f9260fb664 /CMakeLists.txt
parentdc8e84d27a73a0052e6e978cb914420b2999d8bb (diff)
downloadjson-rpc-shell-9aff11b0f5df01dee0414bd56196ef07cfcac5fb.tar.gz
json-rpc-shell-9aff11b0f5df01dee0414bd56196ef07cfcac5fb.tar.xz
json-rpc-shell-9aff11b0f5df01dee0414bd56196ef07cfcac5fb.zip
Fix CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e2f51d..64c643b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,7 +8,8 @@ option (WANT_LIBEDIT "Use BSD libedit for the UI" OFF)
# Moar warnings
if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
# -Wunused-function is pretty annoying here, as everything is static
- set (CMAKE_C_FLAGS "-std=c99 -Wall -Wextra -Wno-unused-function")
+ set (CMAKE_C_FLAGS
+ "${CMAKE_C_FLAGS} -std=c99 -Wall -Wextra -Wno-unused-function")
endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
# Version
@@ -91,7 +92,7 @@ endforeach (page)
add_custom_target (docs ALL DEPENDS ${project_MAN_PAGES})
foreach (page ${project_MAN_PAGES})
- string (REGEX MATCH "\\.([0-9])" manpage_suffix "${page}")
+ string (REGEX MATCH "\\.([0-9])$" manpage_suffix "${page}")
install (FILES "${page}"
DESTINATION "${CMAKE_INSTALL_MANDIR}/man${CMAKE_MATCH_1}")
endforeach (page)