aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2015-02-22 19:15:06 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2015-02-22 20:06:55 +0100
commit855d02acab5a2f679a736fcaa0b88de068b0922b (patch)
treee8bd9eba2bc0cd09f3d10ce0c526b2ef87b53472 /CMakeLists.txt
parent66cf41f89ff8e33413b63a351c05e65b98284b7a (diff)
downloadjson-rpc-shell-855d02acab5a2f679a736fcaa0b88de068b0922b.tar.gz
json-rpc-shell-855d02acab5a2f679a736fcaa0b88de068b0922b.tar.xz
json-rpc-shell-855d02acab5a2f679a736fcaa0b88de068b0922b.zip
Add support for attributed output
Colours, colours, colours. Configurable.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3dbef75..560ebda 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,11 +20,13 @@ set (project_VERSION "${project_VERSION}.${project_VERSION_PATCH}")
set (CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake)
# Dependencies
+find_package (Curses REQUIRED)
find_package (PkgConfig REQUIRED)
pkg_check_modules (dependencies REQUIRED libcurl jansson)
find_package (LibEV REQUIRED)
-include_directories (${dependencies_INCLUDE_DIRS} ${LIBEV_INCLUDE_DIRS})
+include_directories (${CURSES_INCLUDE_DIR}
+ ${dependencies_INCLUDE_DIRS} ${LIBEV_INCLUDE_DIRS})
# Generate a configuration file
configure_file (${PROJECT_SOURCE_DIR}/config.h.in ${PROJECT_BINARY_DIR}/config.h)
@@ -32,7 +34,7 @@ include_directories (${PROJECT_BINARY_DIR})
# Build the main executable and link it
add_executable (${PROJECT_NAME} ${PROJECT_NAME}.c siphash.c)
-target_link_libraries (${PROJECT_NAME}
+target_link_libraries (${PROJECT_NAME} ${CURSES_LIBRARY}
${dependencies_LIBRARIES} ${LIBEV_LIBRARIES} readline)
# The files to be installed