aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 26ea1a7..3c10b34 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,15 +52,6 @@ if (WITH_LUA)
list (APPEND project_libraries ${lua_LIBRARIES})
include_directories (${lua_INCLUDE_DIRS})
link_directories (${lua_LIBRARY_DIRS})
-
- include (CheckTypeSize)
- set (CMAKE_REQUIRED_LIBRARIES ${lua_LIBRARIES})
- set (CMAKE_REQUIRED_INCLUDES ${lua_INCLUDE_DIRS})
- set (CMAKE_EXTRA_INCLUDE_FILES "lua.h")
- CHECK_TYPE_SIZE (lua_Integer LUA_INTEGER)
- if (NOT HAVE_LUA_INTEGER OR LUA_INTEGER LESS 8)
- message (FATAL_ERROR "Lua must have at least 64-bit integers")
- endif ()
endif ()
pkg_check_modules (x11 x11 xrender xft fontconfig libpng)