aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ed3acbe..4a9b411 100644
--- a/meson.build
+++ b/meson.build
@@ -338,6 +338,19 @@ elif meson.is_cross_build()
msys2_root = meson.get_external_property('msys2_root')
meson.add_install_script('msys2-install.sh', msys2_root)
+ # TODO: If we used DESTDIR instead of the prefix, this could probably
+ # be a custom target that invokes "meson install --destdir $(pwd)/package"
+ # through "meson compile -C builddir msi". Try it out, also in MSYS2.
+ meson.add_install_script('msys2-package.sh', host_machine.cpu())
+ configure_file(
+ input : 'fiv.wxs.in',
+ output : 'fiv.wxs',
+ configuration : configuration_data({
+ 'ProjectName' : meson.project_name(),
+ 'ProjectVersion' : meson.project_version(),
+ }),
+ )
+
# This is the minimum to run targets from msys2-configure.sh builds.
meson.add_devenv({
'WINEPATH' : msys2_root / 'bin',