aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index deb6b46..c38458d 100644
--- a/meson.build
+++ b/meson.build
@@ -22,6 +22,14 @@ executable('fastiv', 'fastiv.c', 'fastiv-view.c', 'fastiv-io.c',
install : true,
dependencies : [dependencies])
+# TODO(p): See fastiv_io_open(), consider optionally integrating this.
+gdk_pixbuf = dependency('gdk-pixbuf-2.0', required : false)
+if gdk_pixbuf.found()
+ executable('io-benchmark', 'fastiv-io-benchmark.c', 'fastiv-io.c',
+ build_by_default : false,
+ dependencies : [dependencies, gdk_pixbuf])
+endif
+
install_data('fastiv.desktop',
install_dir : get_option('datadir') + '/applications')
install_data('fastiv.svg',