aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..1295f1d
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,19 @@
+project('fastiv', 'c', default_options : ['c_std=gnu99'], version : '0.1.0')
+
+conf = configuration_data()
+conf.set_quoted('PROJECT_NAME', meson.project_name())
+conf.set_quoted('PROJECT_VERSION', meson.project_version())
+configure_file(
+ output : 'config.h',
+ configuration : conf,
+)
+
+dependencies = [
+ dependency('gtk+-3.0'),
+ dependency('libturbojpeg'),
+]
+
+# TODO(p): we need to create and install a .desktop file
+executable('fastiv', 'fastiv.c', 'fastiv-view.c',
+ install : true,
+ dependencies : [dependencies])