aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2016-11-24 20:32:02 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2016-11-24 20:32:02 +0100
commitff604570fce351dbfbb9e0148f1197188883ff05 (patch)
tree353ad983f3761d2d7ad6e5e477caab93f0873960 /CMakeLists.txt
parent1aeb5b86bb433823cabbf907f69bc87c313888ac (diff)
downloaddesktop-tools-ff604570fce351dbfbb9e0148f1197188883ff05.tar.gz
desktop-tools-ff604570fce351dbfbb9e0148f1197188883ff05.tar.xz
desktop-tools-ff604570fce351dbfbb9e0148f1197188883ff05.zip
fancontrol-ng: install the unit file under /lib
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1d8b307..736b67b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,8 +62,9 @@ include (GNUInstallDirs)
configure_file (${PROJECT_SOURCE_DIR}/fancontrol-ng.service.in
${PROJECT_BINARY_DIR}/fancontrol-ng.service @ONLY)
+# System-wide unit files should be installed under /lib and not /usr/lib
install (FILES ${PROJECT_BINARY_DIR}/fancontrol-ng.service
- DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/systemd/system)
+ DESTINATION /lib/systemd/system)
install (FILES fancontrol-ng.conf.example
DESTINATION ${CMAKE_INSTALL_DATADIR}/fancontrol-ng)