aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2017-07-05 03:09:23 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2017-07-05 03:22:24 +0200
commit5b334e4111794a0de32729f4ebfadba99a3f5dae (patch)
tree27ae93003f0b7706b002c2bd9720367dffff072e /CMakeLists.txt
parentcca674789bbaa10f365ca8da87db6263b67af023 (diff)
downloaddesktop-tools-5b334e4111794a0de32729f4ebfadba99a3f5dae.tar.gz
desktop-tools-5b334e4111794a0de32729f4ebfadba99a3f5dae.tar.xz
desktop-tools-5b334e4111794a0de32729f4ebfadba99a3f5dae.zip
priod: PoC skeleton
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 22afdfd..07b0f51 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,6 +48,9 @@ target_link_libraries (input-switch ${project_libraries})
add_executable (fancontrol-ng fancontrol-ng.c)
target_link_libraries (fancontrol-ng ${project_libraries})
+add_executable (priod priod.c)
+target_link_libraries (priod ${project_libraries})
+
if (WITH_GDM)
include_directories (${gdm_INCLUDE_DIRS})
add_executable (gdm-switch-user gdm-switch-user.c)
@@ -75,11 +78,13 @@ install (FILES ${PROJECT_BINARY_DIR}/fancontrol-ng.service
install (FILES fancontrol-ng.conf.example
DESTINATION ${CMAKE_INSTALL_DATADIR}/fancontrol-ng)
+# TODO: priod is also going to need a systemd unit file
+
if (WITH_GDM)
install (TARGETS gdm-switch-user DESTINATION ${CMAKE_INSTALL_BINDIR})
endif (WITH_GDM)
-install (TARGETS wmstatus brightness input-switch fancontrol-ng siprandom
+install (TARGETS wmstatus brightness input-switch fancontrol-ng priod siprandom
DESTINATION ${CMAKE_INSTALL_BINDIR})
install (PROGRAMS shellify DESTINATION ${CMAKE_INSTALL_BINDIR})
install (FILES LICENSE DESTINATION ${CMAKE_INSTALL_DOCDIR})