aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2016-01-27 20:22:49 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2016-01-27 20:22:49 +0100
commit2825c899617cefc872198296f83572ec3504db93 (patch)
treecea42879f0cb488950576827ea87088bac4ab213 /CMakeLists.txt
parent99081814671c28f30540e81af7ae73096ba4b9e0 (diff)
downloaddesktop-tools-2825c899617cefc872198296f83572ec3504db93.tar.gz
desktop-tools-2825c899617cefc872198296f83572ec3504db93.tar.xz
desktop-tools-2825c899617cefc872198296f83572ec3504db93.zip
Add gdm-switch-user, run by dwmstatus
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e37b106..b5e03bc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,6 +25,9 @@ include (AddThreads)
find_package (PkgConfig REQUIRED)
pkg_check_modules (dependencies REQUIRED libpulse x11)
+pkg_check_modules (gdm gdm glib-2.0 gio-2.0)
+
+option (WITH_GDM "Compile with GDM support" ${gdm_FOUND})
set (project_libraries ${dependencies_LIBRARIES})
include_directories (${dependencies_INCLUDE_DIRS})
@@ -44,6 +47,12 @@ target_link_libraries (brightness ${project_libraries})
add_executable (fancontrol-ng fancontrol-ng.c)
target_link_libraries (fancontrol-ng ${project_libraries})
+if (WITH_GDM)
+ include_directories (${gdm_INCLUDE_DIRS})
+ add_executable (gdm-switch-user gdm-switch-user.c)
+ target_link_libraries (gdm-switch-user ${gdm_LIBRARIES})
+endif (WITH_GDM)
+
# The files to be installed
include (GNUInstallDirs)
@@ -54,6 +63,10 @@ install (FILES ${PROJECT_BINARY_DIR}/fancontrol-ng.service
install (FILES fancontrol-ng.conf.example
DESTINATION ${CMAKE_INSTALL_DATADIR}/fancontrol-ng)
+if (WITH_GDM)
+ install (TARGETS gdm-switch-user DESTINATION ${CMAKE_INSTALL_BINDIR})
+endif (WITH_GDM)
+
install (TARGETS dwmstatus brightness fancontrol-ng
DESTINATION ${CMAKE_INSTALL_BINDIR})
install (PROGRAMS shellify DESTINATION ${CMAKE_INSTALL_BINDIR})