aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2017-07-06 12:45:58 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2017-07-06 12:45:58 +0200
commit047a55640ce4c194e5b99266b59d4175efeae058 (patch)
tree132cdddfc04b0e35a2877d693c3fa2ef1499d60a /CMakeLists.txt
parent38300c037592fbbd09059bb3e728ae4702062245 (diff)
downloaddesktop-tools-047a55640ce4c194e5b99266b59d4175efeae058.tar.gz
desktop-tools-047a55640ce4c194e5b99266b59d4175efeae058.tar.xz
desktop-tools-047a55640ce4c194e5b99266b59d4175efeae058.zip
Add iexec
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b93fbd7..4ce01ee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,6 +51,9 @@ target_link_libraries (fancontrol-ng ${project_libraries})
add_executable (priod priod.c)
target_link_libraries (priod ${project_libraries})
+add_executable (iexec iexec.c)
+target_link_libraries (iexec ${project_libraries})
+
if (WITH_GDM)
include_directories (${gdm_INCLUDE_DIRS})
add_executable (gdm-switch-user gdm-switch-user.c)
@@ -90,8 +93,8 @@ if (WITH_GDM)
install (TARGETS gdm-switch-user DESTINATION ${CMAKE_INSTALL_BINDIR})
endif (WITH_GDM)
-install (TARGETS wmstatus brightness input-switch fancontrol-ng priod siprandom
- DESTINATION ${CMAKE_INSTALL_BINDIR})
+install (TARGETS wmstatus brightness input-switch fancontrol-ng priod iexec
+ siprandom DESTINATION ${CMAKE_INSTALL_BINDIR})
install (PROGRAMS shellify DESTINATION ${CMAKE_INSTALL_BINDIR})
install (FILES LICENSE DESTINATION ${CMAKE_INSTALL_DOCDIR})